[Solved] Where is alire putting things? How do I find this? How do I remove things it's installed?

The actual bug I’m trying to solve is why a newly installed Ada Language Server running in Codium doesn’t seem to run gnatpp. As far as I can tell, gnatpp isn’t installed on my system.

An earlier conversation on this forum informs the user that gnatpp can be found in libadalang_tools. But I’ve installed that and (a) ALS still doesn’t seem to find gnatpp, (b) I can’t find it anywhere in the alire locations, either.

Did I break the install of libadalangtools by putting my laptop to sleep in the middle of the build? If so, I’d like to uninstall it, but I can’t. uninstall is unknown to Alire. We can’t uninstall something once it’s installed?

I’ve found several places where alire dumps things, and while several libadalang_tools libraries appear, gnatpp does not. Did something change? If so, how do I grab gnatpp?

You can run alr version to display various bits of information about your Alire setup, including the cache and build folders.

What platform/OS are you on?

1 Like

Thanks! I didn’t think alr version would tell me all that.

alr version:               2.0.1
libalire version:          2.0.1
compilation date:          2024-03-21 11:06:29
compiled with version:     13.2.0
distribution:              FEDORA
host-arch:                 X86_64
os:                        LINUX
target:                    NATIVE
toolchain:                 USER
word-size:                 BITS_64

Fwiw, neither did i. :slight_smile: i initially assumed i’d find such information via alr config / alr settings.

1 Like

If you run alr install on a binary crate (e.g. libadalang_tools), the executables end up in ~/.alire/bin. You can override this with --prefix=DIR.


Thanks. Not sure why I didn’t notice that, since I did notice ~/.alire/bin. Turns out gnatpp is there, and alire was finding it the entire time. The problem is that gnatpp is still not ready for 'Reduce expressions. :face_with_diagonal_mouth: