Using GtkAda with alire

I installed GtkAda using alire and created a project/crate that uses it. This works so far but each time I issue ‘alr edit’ the post fetch actions are executed which involves a complete build of GtkAda.

If I run GNAT studio from the command line gtkada.gpr is not found.

I wonder if there is to keep alire from doing a compete build of GtkAda?

I’m using alire 1.2.1 as unfortunately my Linux system is too old for alire 2.0.

Update: I now figured out how to set GPR_PROJECT_PATH so that gnatstudio finds gtkada.gpr. But that doesn’t keep alr edit from rebuilding GtkAda.

Look for alr edit.It is probably a solution for your case.

Well, as I wrote, alr edit works, but before launching Gnat studio it performs a complete build of GtkAda (even if the build already happened before), which is somewhat annoying.

Oh, sorry, it’s clear I didn’t pay enough attention.

I tried to reproduce it myself with Alire 2.0, which is the version I’m using, and wasn’t able to do it, so it is either solved with these versions (gtkada or Alire), or something in your setup triggers it.

My steps were:

  alr init test_gtkada
  cd test_gtkada/
  alr with gtkada
  alr build
  alr edit

The selected gtkada version is “24.0.0”.

You could try using your alr 1.2.1 to build the alire v2.0.1 sources?

1 Like

That worked. The problem disappeared with Alire 2.0.1. Thanks.

1 Like